
 
 
 

 
 
 
 
 
 
 
 

Welcome to FasTrack! Getting started is easy. 
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Getting Started - Let’s Track! 
 
At the FasTrack intro screen, click the “Create New Project” button. Once at the main FasTrack 
window, click the “Import Media” button at the top left. 
 
FasTrack allows you to work with 360 degree video, as well as standard 2D video in portrait and 
landscape modes. When you import your footage, FasTrack will automatically detect the type of 
footage. In the rare event that FasTrack is not able to detect your footage type correctly, it may 
look strange initially. Simply go to the “View” menu and change the FasTrack viewer to the 
correct type for your video.  
 
 

 
The new project screen. 
 
If you’re working with 360 degree footage, you have a couple of additional viewing options. 
Select your preference from the drop down menu at the lower right of the main FasTrack 
window, next to the “Export 3D Scene” button. You can view 360 degree video in Cube view, 
equirectangular, or cube map formats.  
 
 

 
 
TIP: ​You can click and drag on the main viewing window in 360 viewing mode to pan the 
footage. 
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Cubemap view of 360 degree footage. 

 
Workflow 
 
The FasTrack workflow was designed to be simple and fast, so you can focus on creating. 
There are five main components: 
 
1. Masking 
2. Camera Calibration 
3. Camera Tracking 
4. Quality Assessment and Asset Placement 
5. Exporting 
 
1. Masking 
 
Masking allows you to select areas of video footage to focus the camera tracker. FasTrack will 
automatically select suitable features for tracking, but you have additional flexibility to control 
this process with masking. There are typically two types of situation you’ll need to deal with: 
moving objects and foreground/background disparities. 
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Moving Objects 
 
Objects that do not have fixed positions in the world of the video footage (e.g. moving cars, 
people walking or moving their arms, bike handlebars visible from a helmet cam) create 
measurement noise when tracking camera positions. It is best to track fixed objects like 
buildings, stationary cars, or the ground.  
 
 

 
The handlebars, arms and camera watermark at the bottom of this shot need to be masked out, as do moving objects 
such as cars, buses and people. 
 
 
Foreground / Background Disparities 
 
Large differences in the distance between foreground and background features can cause 
measurement error during tracking. This is primarily an issue in outdoor scenes, but can occur 
indoors as well. As a general rule, masking out background areas will typically result in a better 
track. However, sometimes it’s necessary to experiment. Each shot is a bit different, and 
tracking quality can change depending on where in your scene you wish to place assets. 
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Tracking this rock formation without the background produces best results for assets placed in the foreground. 
 
 
Creating Your Mask 
 
Creating your mask is easy. Click the “Track Mask Editor” button on the left side of the FasTrack 
window. Right clicking on the viewing window will bring up the mask toolbox. Here, you can 
select your brush type (square or circle) and size, and insert keyframes. Keyframes allow you to 
adjust your mask as the scene evolves. You can add one keyframe per video frame if 
necessary, but for many shots, a few keyframes is fine. To create a dynamic mask: 
 

1) Insert a new keyframe 
2) Paint your mask 
3) Advance forward through the video until you need to make an adjustment 
4) Repeat as necessary 

 
Note that you can delete mask areas by holding down the shift key and painting. You can also 
delete keyframes by clicking “Delete keyframe” from the mask toolbox. 
 
 

 
 
TIP: ​You can go forward or backward by a single frame quickly using the left and right arrow 
keys. Make sure you’ve clicked in the FasTrack viewing window to activate it! 
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This shot required placement of graffiti on the road, so it was best to mask out everything else. 
 
 
AI Assisted Tracking 
 
Some scenes have many moving objects and require detailed masking. To speed up this 
process, you can use the AI Segmentation module. The AI module will search through each 
video frame and try to mask out any objects that you select. If you have any keyframe masking 
that you want to do manually, make sure to do this before doing AI masking. This is because the 
AI module will create a keyframe for every single video frame, and subsequent manual editing 
will be difficult.  
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If you’ve taken care of manual masking, and you still need to mask out other objects, click the AI 
Segmentation button inside the mask editor, or select “AI Segmentation” from the Tools menu. 
 
 
In the AI Masking module, there are multiple ways to add objects you wish to mask. Scroll 
through the list and select, then click the right facing arrow. Alternatively, you can type a search 
parameter to bring up relevant objects. You can also remove objects from the list if you need to, 
by selecting the output filter box and clicking the left arrow.  
 
Once you have selected the objects you want to mask, you’ll want to increase your mask 
padding according to your video size. Mask padding ensures that entire objects get covered 
with margin, so that corners and edges on your objects don’t get selected for tracking. A value 
between 20 and 60 is generally acceptable. You can preview the results of the segmentation by 
clicking the “Start” button. If it looks good, simply wait until tracking is finished and FasTrack will 
add the new masks to the scene.  
 
 

 
 
TIP:​ you can click “Invert mask” to mask everything ​not ​selected for masking. This provides 
more creative masking options. 
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The AI Segmentation module. 
 
 
2. Camera Calibration (Non 360 degree footage only) 
 
For any 2D footage, you’ll want to calibrate your camera if possible. Unlike 360 degree footage, 
2D footage requires knowledge of the camera’s focal length in order to get a good track. There 
are two ways to do this in FasTrack, automatic and manual camera calibration. 
 
Automatic Calibration 
 
To automatically calibrate FasTrack’s camera model, select “Focal length auto calibration” from 
the Tools menu. Make sure you have completed any masking required for your track prior to 
calibration. 
 
Most scenes will calibrate based on the default initial focal length of 1500px. If you have a wide 
angle or telephoto camera, you can try selecting these camera types from the drop down menu.  
 
Advanced settings can give you more control over the process. Use the slider to select different 
regions of the scene to use for calibration. Typically, sections of the shot with more parallax / 
rotational motion are best. Set “max iterations” higher than 5 if you want to attempt to refine the 
focal length estimate further. The “Calibration tolerance in px” determines how small the 
changes in calibration refinement have to be before the algorithm stops trying to improve. 
Lowering this value allows for greater refinement of the focal length approximation.  
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You can also try adjusting the number of frames used in the calibration. The “Random uniform 
sampling” numbers allow for changes here. The algorithm will retrieve the desired number of 
frames from a maximum offset from the start of the calibration region. Typically 20 is best, but 
for some shots, increasing to 30 may help. It’s generally a good idea to keep some visual 
continuity between frames, so don’t set the offset too high, 100 is usually enough. 
 
You can also adjust the density of features used in the calibration. As always, experimentation 
with all of these values can help you solve difficult tracks. 
 
Once you have chosen your settings, hit start to begin. It’s helpful to watch the output of the 
algorithm as it runs. Keep an eye on the “delta” value, this indicates how much the current 
iteration changed it’s current guess from the previous one. If this number is immediately very 
small, or gets larger over time, there’s a good chance the scene is too difficult to calibrate well. 
You may want to adjust settings and try again. When things are going well, the delta typically 
starts large and gets a bit smaller with each iteration. 
 
 
Manual Calibration 
 
For some difficult shots, it’s difficult to get a good automatic calibration. In this case, you have 
two options. You can try manually setting the focal length parameter in the main FasTrack 
window, and then attempt to track the scene at different manual settings. Good settings usually 
range between 800px and 2500px. Depending on what you’re trying to achieve, you don’t 
necessarily need a perfect focal length. As always, experiment! 
 
If you have access to the camera that shot the footage, and you need a very accurate estimate, 
you can use the manual calibration tool from the Tools menu. 
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Using the camera you used for your footage, take still images or video of the checkerboard 
pattern on the screen from several different angles.  
 
 

 
 
TIP:​ Make sure the video mode you acquire these from is the same as that used to shoot the 
footage you’re tracking! 
 

 
 
 
If you created a video file of the checkerboard, extract between 10 and 20 still frames from 
different angles, and make sure there is as little blur as possible. Once you have the images, 
copy the files into their own folder on your computer and hit the “Open” button in the manual 
calibration window to select that folder. Then hit the “Calibrate” button to proceed. 
 
 
3. Camera Tracking 
 
Once you have masked and (if using 2D footage) calibrated, it’s time to track. Click the “Track 
Scene” button on the left side of the FasTrack window to open the tracking module. 
 
 

 
 
TIP: ​Although FasTrack can work with resolutions up to 8k, it’s fastest to downsample your 
footage to 1080p to get your track. This allows you to iterate faster and try more tracks. You 
generally shouldn’t experience a loss in track quality because of the resolution change. 
 
TIP: ​The focal length required for tracking will change if you downsample your footage! If you 
cut your resolution in half, cut your focal length in half. 
 

 
 
 
FasTrack allows you to track in the native resolution of your footage, or in lower resolutions for 
faster tracking. Select your desired resolution from the drop down menu.  
 
If you have not yet cached frames for this video, you’ll have the option to do so with the “Cache 
frames” check box. Checking this box will make multipass tracking faster, and should usually be 
left checked. 
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Under the “Advanced Options” tab, you can choose to change the number of automatically 
generated tracking features (keypoints), or invert your mask. As always, the defaults should get 
you started, but experimentation will help you get great results from tougher tracks. Inverting 
your mask can give you more creative options for tracking tough shots. 
 

 
 
TIP: ​If your track fails to initialize, the three best things to try are: increasing the number of 
keypoints to track, adjusting your focal length, and starting the track at a different location. 
 

 
 
 
As with camera calibration, you can choose the region to start the algorithm. While many shots 
can be tracked from the beginning, some shots will only track well when started at an offset. If 
your shot isn’t initializing, try tracking from midway or at the end of the scene. Experimentation 
will help you learn what works best for a given situation. 
 

 
 
TIP: ​The camera tracking algorithm is stable, but non-deterministic. This means that you can get 
different results sometimes by just running it again from the same settings. For difficult tracks, it 
may be necessary to try running the track several times to get it right! 
 

 
 
If your track is successful, FasTrack will report that tracking is complete, and you’ll head back to 
the main viewing window. Here, you’ll be able to see the landmarks (represented as small 3D 
crosses) generated from features that were tracked. 
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4. Quality Assessment and Asset Placement 
 
Once you have your track data, it’s time to check for quality. It’s not uncommon for the tracking 
algorithm to run to completion and to have shaky tracking data. If this happens, you’ll need to try 
tracking again or change your masking, calibration, or tracking settings. 
 
For 360 degree footage, you have a couple of extra options. Click the “Show stabilized” box at 
the left of the screen to stabilize shaky video. Note that removing camera shake affects the look 
direction of the camera. You can adjust the smoothness of the changes to the camera’s look 
direction after stabilization using the slider, or you can lock the camera in a single direction 
using the “Fix camera” checkbox. 
 
There several ways you can evaluate the quality of your track. The first is to just hit the “play” 
button at the bottom of the video window, making sure the “Show track marks” checkbox at the 
left side of the FasTrack window is ticked. Watch the locations of the landmarks generated by 
the tracker. If there is noticeable movement, i.e. your landmarks aren’t “sticking” to objects in the 
video, your track may not be good enough for asset placement. 
 
 

 
 
TIP: ​You might get a few “floating” points in your track that don’t seem to be attached to 
anything. This doesn’t necessarily mean your track is bad! If most landmarks look good, try 
placing your asset where you need it, and then see if it sticks. Whether your asset looks good in 
place is the ultimate test of whether the track succeeded, no matter what else is going on. Note 
that some landmarks might come from regions behind a wall or other object, so look like they’re 
floating but are actually attached to objects visible from other frames in the video sequence. 
 

 
 
 
Another way to check your track quality is with the 4-split view. Click “4 Split” in the drop down 
menu at the bottom left of the main viewing window to enter this viewing mode. 4-split allows 
you to inspect your camera track from 3 angles while you watch the original footage. You can 
zoom in or out by using your mouse wheel, or pan the location of each window by clicking and 
dragging. The blue line shows the path of the camera, and the white “camera” icon shows the 
position of the camera at each frame. 
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The 4-split view. Note at the top left window that the track (blue line) is smooth, indicating things worked well. This is 
unlike the below image, which shows the same track with problems. 
 

 
The top left window in the 4-split view shows sudden, jagged changes to the camera path, indicating the track will be 
poor in these frames. 
 
 
Take a look at your camera track (the blue line) in each of the three views. If you see sudden 
jagged motions, or discontinuities, you should try your track again until these disappear.  
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If you’re not able to make the discontinuities completely disappear, you still have a couple of 
options. If the discontinuities don’t affect your asset in the final render, i.e. your asset is out of 
view or imperceptible at the time of the discontinuity, you should be okay. If the discontinuity 
affects your asset placement, but the problem only occurs over a small number of frames, you 
can always manually fix key framing in your VFX editor. Sometimes just a quick linear 
interpolation over the exported keyframe data can get the job done! 
 
If you think your track is good, it’s time to try placing some assets.  To begin, find a landmark 
near the location you like to place your asset and double click on it to bring up the asset 
placement toolbox.  
 
 

 Create text  Add an image 

 Create a null object  Delete current landmark 

 Delete landmarks around this area  Create a plane 
 
 

 
Depending on the complexity of your scene, you may want to immediately add the exact image 
or text you want in FasTrack, or you may want to insert a placeholder like a null or solid so that 
you can insert the asset later in your FX editor of choice. 
 
Once you’ve added your asset, it appears in the “Object List” at the top right of the FasTrack 
window. Clicking on the asset in the viewing window or on the object list will bring up the 
object’s parameters. You can adjust rotation and translation using the in-video widget, or enter 
values in the parameters box to the lower right. To delete an asset, click the trash icon to the 
right of the respective object in the list that pops up when you hover the mouse cursor over it. In 
some cases, you can change the asset by clicking on the pencil icon that appears. 
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Editing asset parameters. 
 
 

 
 
TIP: ​If you’re placing an asset on a fixed surface, e.g. a sign on a wall, make sure the sign is 
aligned perfectly to the tracking data for the wall. If you’ve done this and your object still looks 
shaky relative to the surface it’s supposed to be on, it might just need to be placed in a slightly 
different location. Try placing your asset slightly more in front or behind (or above or below) the 
location, and see how this affects stability.  
 

 
 
 
If you’re still unable to place your asset correctly after some trial and error, it may be an 
indication that you need to re-track. Alternatively, if the problem is small, you can likely fix things 
with some minor keyframing in your VFX editor. 
 
5. Exporting 
 
Once your asset placement looks good, it’s time for exporting your data to your favourite VFX 
editor. Click on the “Export 3D Scene” button in the lower left corner of the FasTrack window, or 
select “Export 3D Scene” from the file menu. 
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Here, you can select the application you would like to export to using the top-most drop down 
menu. 
 
 
Export to Apple Motion 
 
Camera Path Smoothing:​ This only applies to 360 degree video. Use this to choose how your 
original camera direction is rendered during export if you used stabilization. 
 
Target Media: ​If you were working with a frame sequence, select the frame sequence radio 
button here and make sure the correct folder is indicated in the “Target Video Settings”. By 
default, you should use a video file. FasTrack will automatically try to select the option that 
works with your project. 
 
Target Video Settings: ​These settings control the data export. Most should be left as the 
default. FasTrack will try to automatically identify the correct frame rate for your video, but be 
sure to check that it is correct! Even slightly incorrect frame rates can create large errors in the 
quality of the export. 
 
Open Apple Motion After Export: ​Check this box to automatically open Motion with your 
project after hitting the export button. 
 
After exporting, to begin working with your footage in Motion all you need to do is select “Active 
Camera” from the drop down menu at the top left of the video window. Then, select the “Fit” 
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option from the drop down menu near the top right of the video window. Hit the playback button 
to see how things look. That’s it! 
 

 
A project exported to Motion. 
 
Export to Blender 
 
Select checkboxes to export landmarks, nulls and overlays according to your needs. 
 
Export landmarks count: ​This allows you to select the number of landmarks to export. 
Landmarks are helpful as a guide for asset placement, but you usually don’t need all of them. 
Select a lower number to increase rendering performance in Blender. 
 
Target App: ​The COLLADA file standard supports different applications, but currently only 
Blender 2.9 is tested and supported. 
 
Frame Rate: ​FasTrack detects this automatically, but check to make sure it’s correct! Even 
small errors in frame rate can create large errors in the export quality of a track. 
 
Camera path smoothing: ​This only applies to 360 degree video. Use this to choose how your 
original camera direction is rendered during export if you used stabilization. 
 
Once your file is exported, importing tracking footage into Blender is easy. ​Before importing 
your dae file,​ ​be sure to set the correct resolution and frame rate for the video in the 
“Output properties” box at the lower right.​ Then input the number of total video frames, so 
that “Frame Start” is 1, and “End” is set to the total number of frames (You can use 
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“View->Show Project Info” in FasTrack to see how many frames are in the video, as well as its 
frame rate). 
 
 

 
      The output properties tab (lower right of the Blender window). 
 
Delete any default objects and cameras so you have an empty scene, and import your file via 
the File->Import menu. 
 
2D Footage In Blender 
 
After the above steps, select your camera in the “Scene collection” (top right), and click on the 
“Object data properties” icon (a small green camera toward the lower right). Click the 
“Background Images” tab and click “add image”.  
 

 
                                 The object data properties tab (lower right). 
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Click the “Background Images” tab to expose the “Add Image” button. 

 
 
Then select “Movie Clip” and open the video you tracked. You may need to adjust the starting 
and ending frames via the “output properties tab” (small printer icon).  
 
360 Degree Footage in Blender 
 
After completing the above steps to export your dae file and import it into blender, select the 
“Screen” asset in the “Scene Collection” list at the top right. Then, click the materials properties 
tab at the lower right. 
 

 
Selecting the screen tab.    The material properties tab. 
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In the material properties tab, click on the small circle beside the “Base Color” cell, and select 
“Image Texture” from the menu that appears. Click the “Open” button immediately below the 
“Base Color” cell, and select your footage from the file dialogue window. Next, click the “Auto 
Refresh” checkbox in the material properties tab, below the name of your video clip. Enter the 
number of total frames in the video in the “Frames” cell. 
 
Next, click the “Shading” tab at the top of the Blender screen. Here, we need to horizontally flip 
the movie so it views correctly and aligns with our tracking information. 
 

 
Adding texture coordinate and vector mapping nodes. 

 
In the node editing window at the bottom of the shading tab,  
 

1) click the “Add” menu. Add “Input->Texture Coordinate” and “Vector->Mapping” nodes, 
and place them as the image above.  

2) Wire (by clicking and dragging) the “Color” attribute of the movie clip node to the 
“Emission” attribute of the “Principled BSDF” node.  

3) Wire the “Vector” attribute of the “Mapping” node to the “Vector” attribute of the movie 
node.  

4) Wire the “UV” attribute of the “Texture Coordinate” node to the “Vector” attribute of the 
“Mapping” node. 

5) Change the value of the “X” attribute in the “Scale” parameter of the “Mapping” node to 
-1.0, instead of 1.0.  
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When you’re finished, the node mappings should look as they do in the above image, and you 
should see the image flipped over the horizontal axis. 
Now, click on the “Layout” tab at the top of the main window, and hit the zero key to enter 
“Camera Perspective” mode. Finally, hit the “Z” key on your keyboard, and select “Rendered” 
mode. You should now be able to hit the play button at the bottom of the Blender window, and 
see your landmarks and any assets overlaid correctly with the video. 
 
 
 
Conclusion 
 
We hope you enjoy FasTrack and that it elevates your creative potential!  
 
If you have any problems with your software, please contact us at: 
 
contact@gofox.ai 
 
Happy Tracking! 
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